-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy path数的划分算法提高.c
66 lines (58 loc) · 897 Bytes
/
数的划分算法提高.c
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
/*
问题描述
一个正整数可以划分为多个正整数的和,比如n=3时:
3;1+2;1+1+1;
共有三种划分方法。
给出一个正整数,问有多少种划分方法。
输入格式
一个正整数n
输出格式
一个正整数,表示划分方案数
样例输入
3
样例输出
3
数据规模和约定
n<=100
*/
#include<stdio.h>
void copy(int ,int l,int [][l]);
int q_way(int,int l,int [][l]);
#define zd 100
int main(void)
{
int n;
scanf("%d",&n);
int arr[zd][zd];
copy(n,n,arr);
printf("%d\n",q_way(n,n,arr));
}
void copy(int n ,int l,int arry[][l])
{
int i;
for(i=0;i<=n;i++)
{
arry[i][1]=1;
arry[0][i]=1;
}
}
int q_way(int n,int l,int arr[][l])
{
int i;
for( i=1;i<=n;i++)
{
int j;
for(j=1;j<=n;j++)
{
if(j<=i)
{
arr[i][j]=arr[i][j-1]+arr[i-j][j];
}
else
{
arr[i][j]=arr[i][i];
}
}
}
return arr[n][n];
}