-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathSkillenza- HCL-Java Microservices | Hiring Challenge by HCL-Diamonds of Diamonds problem.java
137 lines (124 loc) · 2.61 KB
/
Skillenza- HCL-Java Microservices | Hiring Challenge by HCL-Diamonds of Diamonds problem.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
/*Diamond of Diamonds
Given width of diamond, output the diamond pattern as shown below
For width 2, the pattern is
/\
\/
/\ /\
\/ \/
/\
\/
For width 1, the pattern is
/\
\/
For width 4, the pattern is
/\
\/
/\ /\
\/ \/
/\ /\ /\
\/ \/ \/
/\ /\ /\ /\
\/ \/ \/ \/
/\ /\ /\
\/ \/ \/
/\ /\
\/ \/
/\
\/
Input Format
The first line of input consists of an integer t denoting the number of test cases. Next t test cases follow. Each test case consists of one line. Each line of test case consists of an integer w denoting the width of the diamond.
Output Format
For each test case output the diamond pattern.
Constraints
1 <= t (number of test cases) <= 100
1 <= w (width of diamond) <= 100
Sample Input
2
5
3
Sample Output
/\
\/
/\ /\
\/ \/
/\ /\ /\
\/ \/ \/
/\ /\ /\ /\
\/ \/ \/ \/
/\ /\ /\ /\ /\
\/ \/ \/ \/ \/
/\ /\ /\ /\
\/ \/ \/ \/
/\ /\ /\
\/ \/ \/
/\ /\
\/ \/
/\
\/
/\
\/
/\ /\
\/ \/
/\ /\ /\
\/ \/ \/
/\ /\
\/ \/
/\
\/
Environment
Read from STDIN and write to STDOUT.
#solution */
import java.util.*;
import java.lang.*;
class main{
public static void main(String args[])
{
Scanner sc=new Scanner(System.in);
int t=sc.nextInt();
while(t>0)
{
int n=sc.nextInt();
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n-i;j++)
{
System.out.print(" ");
}
for(int j=1;j<=i;j++)
{
System.out.print("/\\ ");
}
System.out.println();
for(int j=1;j<=n-i;j++)
{
System.out.print(" ");
}
for(int j=1;j<=i;j++){
System.out.print("\\/ ");
}
System.out.println();
}
for(int i=n-1;i>=1;i--)
{
for(int j=1;j<=n-i;j++)
{
System.out.print(" ");
}
for(int j=i;j>=1;j--)
{
System.out.print("/\\ ");
}
System.out.println();
for(int j=1;j<=n-i;j++)
{
System.out.print(" ");
}
for(int j=i;j>=1;j--){
System.out.print("\\/ ");
}
System.out.println();
}
t=t-1;
}
}
}